Microwave Office Training

Non-Linear Simulation

Summary

- Harmonic Balance Simulation is used for Steady State Frequency Analysis
- Ports - Setting Power
- Frequencies - Where Controlled
- Example - Medium Power Amplifier
  - DC VI Curves for a Transistor.
  - Large signal S parameters.
  - Power measurements.
  - Output Equations.
  - Sweeping Power.
Harmonic Balance

- Used for nonlinear, frequency domain simulations
- Uses fundamental frequencies and their harmonics:
  - Frequency 1: $\omega_1$ - fundamental. $2\omega_1$, $3\omega_1$, ..., - harmonics
  - Frequency 2: $\omega_2$ - fundamental. $2\omega_2$, $3\omega_2$, ..., - harmonics
  - Intermodulation Products: Example: $2\omega_1 - 3\omega_2$
- The ports excite the circuit with a certain amount of power - and the response in the various harmonics is obtained.
- Can control the power levels, fundamental frequencies, and intermodulation products.

Harmonic Balance Settings

Harmonic Balance Settings are in: Options > Circuit Options
(They also can be set at the individual circuit level.)
Tip: Leave the convergence settings and advanced settings alone unless you have convergence issues.

Fundamental Tones and their Harmonics

Tip: You can have up to 8 fundamental tones - but you have to set it up in the source element.

Sets maximum intermod product order

Tip: Intermod order is: $N_1 + N_2$ where the intermod freq is: $N_1\omega_1 \pm N_2\omega_2$
Harmonic Balance Ports

They are all under the elements: Ports > Harmonic Balance

The available input power is set in all of them.

Some can set more than one fundamental frequency:

PORT2
P=2
Z=50 Ohm
f0=0.1 GHz
Pwr1=0 dBm
Pwr2=0 dBm

PORTF
P=3
Z=50 Ohm
f0=1 GHz
Pwr=0 dBm

as a delta freq. or Completely from Tone 1 Independently

Tip: When these ports are not exited or used in linear analysis - they act like normal, linear ports.

Simulation Frequencies

For a 1 tone source -

• The fundamental tone is set at the project or circuit frequency level.

• Each fundamental and its harmonics are simulated in order.

Fundamental Tone

Tip: Harmonic 0 is DC.

- 1.0  2.0  3.0  4.0  5.0
- 1.1  2.2  3.3  4.4  5.5
- 1.2  2.4  3.6  4.8  6.0
Example - Power Amplifier

IV Curves for a Transistor

Step 1. In a new project - import the schematic - NE_71300L_1.sch.

Rename it to: Biased FET.

Note: This is a model, so HB will be able to work with DC.

HB always need to calculate the DC point - so if S parameter data, it will have to extrapolate to DC.

Example - Power Amplifier - 2

IV Curves for a Transistor

Step 2: Insert the IV Curve Tracer.

This element is found under
MeasDevice > IV.

Biased FET
Example - Power Amplifier - 3

IV Curves for a Transistor

Step 3: Add a Graph - “Device Dynamic IV”
- Add the measurement - IVCurve. (This measurement is under Nonlinear > Current.)

Note - The simulator is HB.

Example - Power Amplifier - 4

Biasing the Transistor.

We pick an operating point of
- \( VDD = 3 \text{ V} \).
- \( VGS = -1.2 \text{ V} \).

Step 3: Create a new schematic - “PA Small Signal”.
- Change the project frequencies to: 0.2 to 20 GHz in 0.2 GHz steps.
**Example - Power Amplifier - 5**

**Small Signal Gain**

Step 4: Create a graph - “Gain”. Add S21. (Under Linear > Port Parameters)

Note: This is a linear measurement - about the bias point.

The log scale for frequency was set in the graph properties under: Axes / Limits.
**Example - Power Amplifier - 6**

Small Signal S Parameters

Step 5: Create a graph - “Small Signal Port Parameters”.
- Add measurements S11 and S22.

![Small Signal S Parameters Graph](image)

**Example - Power Amplifier - 7**

Input Matching Network

Step 6: Freeze the Traces for the graphs: Graph > Freeze Traces or Ctrl - F.
This will allow us to see the old and new simulation results.

Step 7: Add the input matching network and resimulate.

![Input Matching Network Diagram](image)
The Gain has been peaked at the desired frequency.

Example - Power Amplifier - 8

Example - Power Amplifier - 9

Step 8: Copy “PA Small Signal” to a new schematic and rename it “PA Harmonic Balance”.

Step 9: Change the linear Port 1 to a HB port of type - Port1.

Note: Don’t confuse “Port 1” - a port name/number with “PORT1” - a type of HB port (1 fundamental frequency.)

Tip: Two quick ways to change the port.
  • Double click on name PORT and retype.
  • RC and Swap Element.
Example - Power Amplifier - 10

Tune over the Available Input Power

Step 10: Create a graph - “Power Measurements”
- Add Measurement S21 for PA Small Signal.
- Add Measurement LSSnm for PA Harmonic Signal. (Nonlinear > Power)

Note: LSS is the measurement for large signal S parameters.

We are making this measurement at the fundamental frequency.

Note: Click the ... to see all possible frequencies.

Example - Power Amplifier - 11

Tune over the Available Input Power

Step 11: Create a global variable for Pin and set it to -10.
Global Variables are set on the Global Definitions page in the browser.

Tip: Hot Key for an equation: Ctrl E
or you can use: Draw > Add Equation.

Pin = -10

Step 12: Set the HB source in “PA Harmonic Balance” power to Pin.

Note that units are dBm in the source. So - Pin variable is dimensionless.
Example - Power Amplifier - 12

Tune over the Available Input Power

**Step 13:** Select Pin with the Tuner. Tune from -10 to 10 dBm and observe the Power Measurements.

Tip: You can change Max and Min of the slider scale.

Compression is Visible at 3.4 dBm power input.

Example - Power Amplifier - 13

Creating a Load Line

**Step 14:** Set the circuit simulation frequency for “PA Harmonic Balance” to 5.5 GHz.

Our fundamental tone is now 5.5 GHz...and 5 harmonics.
Example - Power Amplifier - 14

Creating a Load Line

Step 15: Add voltage and current meters at the output of the transistor.

I_METER and V_METER are located at: MeasDevice.

Note the polarity of the current meter.

Example - Power Amplifier - 15

Creating a Load Line

Step 16: Add the IVDLL measurement to the “Device Dynamic IV” graph.
**Example - Power Amplifier - 16**

Device Dynamic IV

The Dynamic Load Line

**Example - Power Amplifier - 17**

Time Domain Voltage and Current Plots

Step 17: Add an M_Probe to the input port of the device (MeasDevice > Probe.)

MProbes allow you to get voltage and current at any node quickly.

Tip: M_Probe must be placed at nodes only!
Example - Power Amplifier - 18

Time Domain Voltage and Current Plots

Step 18: Add a graph “Time Domain Voltage”.
- Add measurements for the Input and Output voltage using Vtime (Nonlinear > Voltage).

![Graph showing time domain voltage plots with input and output measurements.]

Example - Power Amplifier - 19

Time Domain Voltage and Current Plots

Step 19: Make the labels nicer to indicate input and output voltage.

![Graph showing time domain voltage plots with input and output voltage labels.]

Tip: This is set under the graph properties > Measurements
**Example - Power Amplifier - 20**

**Time Domain Voltage and Current Plots**

Step 20: Move the MProbe to other nodes and see how the voltage changes.

Note: You don’t need to simulate again. The simulation has saved the data at all nodes.

Tip: You have to have the MProbe on a node - or you’ll get an error.

**Example - Power Amplifier - 21**

**Frequency Spectrum of the Output**

Step 21: Create a new graph - “Power Spectrum”.

-Use the measurement - PHarm in dB. (Nonlinear > Power) for both port 1 and 2.

Tip: You may want to disable autoscale for the y axis to get reasonable limits.
Output Equations

- Output equations are used to manipulate measured data in a graph.
- The data are assigned to a variable that can then be used in other equations.
- Output equations are written on the Output Equations page - using an equation wizard.
- You also can write functions in the scripting editor that use the data.
- In this example:
  - We want a different definition of Gain: Pout of Port 2/Power in at Port 1.
  - This is a different definition as Pin - is net power in (i.e. reflected power is included in the definition... This will make a higher gain than the normal definition.

Example - Power Amplifier - 22

Output Equations

Let’s derive input and output power using the voltage and current.

Step 22: Create the following output equations and equations in the Project Browser page.

\[ V_{\text{in}} = \text{PA Harmonic Balance}:V\text{comp}(PORT\_1,1) \]

\[ I_{\text{in}} = \text{PA Harmonic Balance}:I\text{comp}(PORT\_1,1) \]

\[ V_{\text{out}} = \text{PA Harmonic Balance}:V\text{comp}(PORT\_2,1) \]

\[ I_{\text{out}} = \text{PA Harmonic Balance}:I\text{comp}(PORT\_2,1) \]

\[ \text{mismatch} = \text{PA Harmonic Balance}:DB(\text{INMG}(PORT\_1)) \]

\[ \text{Pin} = 10^{\log_{10}(\text{Real}(V_{\text{in}}*\text{Conj}(-I_{\text{in}}))/0.002)} \]

\[ \text{Pout} = 10^{\log_{10}(\text{Real}(V_{\text{out}}*\text{Conj}(-I_{\text{out}}))/0.002)} \]

\[ \text{Gain} = \text{Pout} - \text{Pin} \]

\[ \text{Gain}_\text{mismatch} = \text{Pout} - \text{Pin} - \text{mismatch} \]
Output Equations

The output equations are added by: Draw > Add Output Equation. Equations are added with Draw > Add Equation or Ctrl E.

Select the fundamental frequency
Set the frequency to 5.5 GHz
Use the power as the X axis.

Graphing an Output Equation

Step 23: Add to the graph “Power Measurements” two equations: “Gain” and “Gain_mismatch”.

Don’t use dB - as it is already in dB.
Example - Power Amplifier - 25

Note: Gain includes gain due to the mismatch, which is subtracted out of Gain Mismatch.

Tips on Variables and Equations

Note: When a variable is needed, first the software looks locally, then globally. This is why we could have a “Pin” in Global Definitions and Output Equations.

**Step 24: Create a new schematic “Test Equations”**.

Note: Using a colon will show the value of the variable when simulated.

Simulate to see you get a=4.

**Step 25: Open Global Definitions and put in a=7**.

Verify that a still has value 4 in “Test Equations”.

Pin=3.4

a=7
Tips on Variables and Equations - 2

Step 26: Disable the equation \('a=4\) in “Test Equations”, and verify “\(a\)” now becomes 7.

Step 27: Re-enable “\(a=4\)”. Move “\(a:\)” above the “\(a=4\)” equation. Simulate.

You get 7 not 4!

The reason equations are evaluated on a page from top to bottom, left to right. This is like scripting.
So “\(a=4\)” didn’t exist yet when you asked for a.

Example - Power Amplifier - 21

Sweep Over Input Power

Step 28: Change the input port to a swept input - PORT_PS1.
- Sweep from -30 dBm to 10 dBm in steps of 1 dB.

Example:
- Insert PT - the total power at Port2.
- Insert PComp at Port2 at harmonics 1, 2, 3, and 4.
- Use dBm for all measurements.
Example - Power Amplifier - 22

Sweep Over Input Power

Want the power at Port2.

Set freq to 5.5 GHz.

Use dBm.

Use for X-axis the power out of Port1 - which we are sweeping.

Example - Power Amplifier - 23

Sweep Over Input Power

Swept Power Graph

Want the power at Port2.

Set freq to 5.5 GHz.

Use dBm.

Use for X-axis the power out of Port1 - which we are sweeping.
39 Nonlinear Simulation

Example - Power Amplifier - 24

Sweep Over Input Power

Another way to sweep over input power is to use a swept variable.

Step 30: Copy the PA Harmonic Balance Schematic. Name it: “Swept Variable”.

Step 31: Switch the input port back to PORT1.
- Set a variable: Mypower = 0.

40 Nonlinear Simulation

Example - Power Amplifier - 25

Sweep Over Input Power

Step 32: Insert the control block SWPVAR.
It’s located at: Simulation Control

Note: The equation Mypower = 0 is required because the variable needs to be initialized in the simulator, even though you are using the swept values.

Tip: An advantage of doing things this way is I can disable SWPVAR (RC Disable). I can’t do this with the swept power port.
Example - Power Amplifier - 26

Sweep Over Input Power

Step 33: Make a graph “Power with Swept Variable”.
- Add a measurement PComp for ports 1 and 2 at fundamental.

The swept variable Mypower is used as the x axis.

Example - Power Amplifier - 27

Power with Swept Variable

- DB([Pcomp(PORT_2.1)]*[1.1]) (dBm)
- DB([Pcomp(PORT_1.1)]*[1.1]) (dBm)

Nonlinear Simulation
Example - Power Amplifier - 28

IP3 Measurements

IP3 - is a third order intermodulation product - leading to distortion in band.

Input Frequencies: F1 and F2 = F1 + δF

Third order intermod products include:

• 2F1 - F2 = F1 - δF, which is in band.

3rd order intermod product is getting larger faster (slope = 3), than fundamental (slope = 1) as a function of input power.

Example - Power Amplifier - 29

Step 34: Copy the schematic “Swept Variable” and rename it to: “IP3”.

- Change the input port to type PORT2.
- Fdelt = 10 MHz.
- Set both power levels to “Mypower”.

Note: We now have two independent tones: Tone 1 and Tone 2.
Example - Power Amplifier - 30

Step 35: Change the HB settings to 7 harmonics for Tones 1 and 2.

Located under: Options > Circuit Options

Example - Power Amplifier - 31

Step 36: Create a new graph - “Third Order Harmonic”.
- Plot “PComp” for the fundamental and 3rd order harmonic as a function of power.

You now have to specify which harmonics you want.
Example - Power Amplifier - 32

3rd Order Measurement

Note: Clicking “...” - let’s you pick your frequency.

Example - Power Amplifier - 33

Third Order Harmonic

Fundamental

3rd Order

Linear Extrapolation

Note: The IP3 measurement assumes you are in the linear region.
Example - Power Amplifier - 34

Step 37: Add graph - “IP3”.

- Measurement: Nonlinear > Power > OIPN.

Modify Measurement

Don’t Use dB! (Output already in dBm.)

Example - Power Amplifier - 35

Result Valid ~ 31 dBm

Invalid result - Power too high.

Note: This assumes linear region - which is why it’s in error for higher input powers.